Monday 22 September 2014

CAREER WITH WPF TECHNOLOGY


The Windows Presentation Foundation is Microsofts next generation UI framework to create applications with a rich user experience. It is part of the .NET framework 3.0 and higher.WPF combines application UIs, 2D graphics, 3D graphics, documents and multimedia into one single framework. Its vector based rendering engine uses hardware acceleration of modern graphic cards. This makes the UI faster, scalable and resolution independent. 

Thursday 18 September 2014

“ ntldr missing press any key to reboot the system”


  


How will you remove this error “ ntldr missing press any key to reboot the system” ?

Reboot the system with XP, ( apply also on server2003,) cd
On setup screen press to R to repair the window
Now provide the administrator password
C:\>cd f:( your cd drive latter, f is taken as the example )
f:\>cd i386
f:\>copy ntldr c:\
f:\>exit
reboot the system

All set now

Saturday 6 September 2014

nstalling and enabling IIS and FTP on Windows Server 2008 R2


  • Open Server Manager, go to Roles and click “Add Roles”
1.png
  • In the Add Role Wizard, select Web Server (IIS) role to install
2.png
  • Click Next until you reach Select Role Services page, leave the default and check FTP Server, FTP Service and FTP Extensibility at the bottom. Click Next, follow the wizard and finish the role installation.
3.png
  • Now open IIS Manager from Start > Administrative Tools, expand the server, right click Sites, and click Add FTP Site, give it a site name and configure the physical path as needed.
4.png
  • Configure Binding and SSL. In our case, we’d like to bind to all unassigned IP addresses and do not use SSL.
5.png
  • Enable Basic Authentication and configure authorization. In our case I’ll start with allowing All users both Read and Write permission as long as all users on the server are password protected.
6.png
  • Click Finish to finish the configuration.

  • Open Windows Firewall with Advanced Security from Start > Administrative Tools, go to Inbound Rules in the left pane, and create a new rule by clicking New Rule in the Action Pane, select Port and click next.
7.png
  • Apply this rule to TCP port 21, and click Next
8.png
  • Keep the default configure for the rest of steps to Allow the connection and apply it to all profiles, name the rule and finish the wizard.

  • Now the FTP should be up and running, please test the connection to confirm.

PPP Point to Point Protocol is a Layer 2 WAN Protocol

PPP DESIGN USING CHAP AUTHENTICATION
PPP Overview
PPP Point to Point Protocol is a Layer 2 WAN Protocol. For data transmission between any two nodes or routers, a data path must be established, and flow control procedures must be in place to ensure deliver of data. Point-to-Point Protocol is a data link protocol and its basic purpose is to transport layer-3 packets across a Data Link layer point-to-point network. It is the most widely used and most popular WAN protocol because it offers control of data link set-up, dynamic assignment of IP addresses, network protocol multiplexing, link testing, link configuration, error detection and negotiation options for network-layer address and data compression.

PPP Components

PPP addresses the problems of Internet connectivity by employing three main components:
  • A method for encapsulating datagrams over serial links. PPP uses High-Level Data Link Control (HDLC) as a basis for encapsulating datagrams over point-to-point links.
  • Link Control Protocol (LCP) for setting up, configuring and testing the data link connection.
  • PPP uses Network Control Protocol (NCP) for establishing and configuring different network-layer protocols. PPP is designed to allow the simultaneous use of multiple network-layer protocols (e.g., IP, IPX, Appletalk, ..., etc.)
Authentication
PPP uses two authentication protocols PAP and CHAP. CHAP is the preferred protocol, because CHAP uses 3-way handshake; whereas, PAP uses 2-way handshake.



PAP is less secure than CHAP, passwords are sent in clear text and PAP is only performed upon the initial link set-up. PAP uses a two-way handshake to establish identity.
ROUTER CONFIGURATION
- Authentication between Data Center Router, Service Center and Shaw Butte Routers
     - Hostname of Data Center Router: DataCenter
     - Hostname of Service Center Router: ServiceCenter
     - Hostname of Shaw Butte Router: ShawButte
     - all three routers need to authenticate each other

DataCenter# configure terminalDataCenter(config)# enable password cisco

DataCenter(config)# enable secret class

DataCenter(config)# username ServiceCenter password cisco

DataCenter(config)# username ShawButte password cisco

DataCenter(config)# line console 0

DataCenter(config-line)# login

DataCenter(config-line)# password cisco

DataCenter(config-line)# exit

DataCenter(config)# line vty 0 4

DataCenter(config-line)# login

DataCenter(config-line)# password cisco

DataCenter(config-line)# exit

DataCenter(config)#interface serial 1

DataCenter(config-if)# ip address 150.150.96.1 255.255.224.0

DataCenter(config-if)# encapsulation ppp

DataCenter(config-if)# ppp authentication chap

DataCenter(config-if)# no shutdown

DataCenter(config)#interface serial 2

DataCenter(config-if)# ip address 150.150.96.3 255.255.224.0

DataCenter(config-if)# encapsulation ppp

DataCenter(config-if)# ppp authentication chap

DataCenter(config-if)# no shutdown

DataCenter(config)#interface serial 3

DataCenter(config-if)# ip address 150.150.96.5 255.255.224.0

DataCenter(config-if)# encapsulation ppp

DataCenter(config-if)# ppp authentication chap

DataCenter(config-if)# no shutdown

DataCenter(config)#interface serial 4

DataCenter(config-if)# ip address 150.150.96.7 255.255.224.0

DataCenter(config-if)# encapsulation ppp

DataCenter(config-if)# ppp authentication chap

DataCenter(config-if)# no shutdown

DataCenter(config)#interface serial 5

DataCenter(config-if)# ip address 150.150.64.1 255.255.224.0

DataCenter(config-if)# encapsulation ppp

DataCenter(config-if)# ppp authentication chap

DataCenter(config-if)# no shutdown

DataCenter(config)#interface serial 6

DataCenter(config-if)# ip address 150.150.64.3 255.255.224.0

DataCenter(config-if)# encapsulation ppp

DataCenter(config-if)# ppp authentication chap

DataCenter(config-if)# no shutdown

DataCenter(config)#interface serial 7

DataCenter(config-if)# ip address 150.150.64.5 255.255.224.0

DataCenter(config-if)# encapsulation ppp

DataCenter(config-if)# ppp authentication chap

DataCenter(config-if)# no shutdown

DataCenter(config)#interface serial 8

DataCenter(config-if)# ip address 150.150.64.7 255.255.224.0

DataCenter(config-if)# encapsulation ppp

DataCenter(config-if)# ppp authentication chap

DataCenter(config-if)# no shutdown

DataCenter(config-if)# exit

DataCenter(config)# exit

DataCenter#

The CHAP configuration for Service Center Router:

ServiceCenter# configure terminal

ServiceCenter(config)# enable password cisco

ServiceCenter(config)# enable secret class
ServiceCenter(config)# username DataCenter password cisco

ServiceCenter(config)# username ShawButte password cisco

ServiceCenter(config)# line console 0

ServiceCenter(config-line)# login

ServiceCenter(config-line)# password cisco

ServiceCenter(config-line)# exit

ServiceCenter(config)# line vty 0 4

ServiceCenter(config-line)# login

ServiceCenter(config-line)# password cisco

ServiceCenter(config-line)# exit

ServiceCenter(config)# interface serial 0

ServiceCenter(config-if)# ip address 150.150.96.2 255.255.224.0

ServiceCenter(config-if)# encapsulation ppp

ServiceCenter(config-if)# ppp authentication chap

ServiceCenter(config-if)# no shutdown

ServiceCenter(config-if)# exit

ServiceCenter(config)# exit

ServiceCenter#
A similar configuration should be implemented for the interfaces that range from serial 1 to serial 7, and also for the Shaw Butte Router.


Thanks & Regards
Vijay Vishwakarma 

Friday 5 September 2014

How to Use VMware Workstation

talling VMware Workstation

  1. 1
    Make sure your computer meets the system requirements.Because you will be running an operating system from within your own operating system, VMware Workstation has fairly high system requirements. If you don’t meet these, you may not be able to run VMware effectively.
    • You must have a 64-bit processor.
    • VMware supports Windows and Linux operating systems.
    • You must have enough memory to run your operating system, the virtual operating system, and any programs inside that operating system. 1 GB is the minimum, but 3 or more is recommended.
    • You must have a 16-bit or 32-bit display adapter. 3D effects will most likely not work well inside the virtual operating system, so gaming is not always efficient.
    • You need at least 1.5 GB of free space to install VMware Workstation, along with at least 1 GB per operating system that you install.
  2. 2
    Download the VMware software.You can download the VMware installer from the Download Center on the VMware website. Select the newest version and click the link for the installer. You will need to login with your VMware username.
    • You will be asked to read and review the license agreement before you can download the file.
    • You can only have one version of VMware Workstation installed at a time.
  3. 3
    Install VMware Workstation.Once you have downloaded the file, right-click on the file and select “Run as administrator”.[1]
    • You will be asked to review the license again.
    • Most users can use the Typical installation option.
    • At the end of the installation, you will be prompted for your license key.
    • Once the installation is finished, restart the computer.

EditPart Two of Three:
Installing an Operating System

  1. 1
    Open VMware. Installing a virtual operating system is much like installing it on a regular PC. You will need to have the installation disc or ISO image as well as any necessary licenses for the operating system that you want to install.
    • You can install most distributions of Linux as well as any version of Windows.
  2. 2
    Click File. Select New Virtual Machine and then choose Typical. VMware will prompt you for the installation media. If it recognizes the operating system, it will enable Easy Installation:
    • Physical disc – Insert the installation disc for the operating system you want to install and then select the drive in VMware.
    • ISO image – Browse to the location of the ISO file on your computer.
    • Install operating system later. This will create a blank virtual disk. You will need to manually install the operating system later.
  3. 3
    Enter in the details for the operating system. For Windows and other licensed operating systems, you will need to enter your product key. You will also need to enter your preferred username and a password if you want one.
    • If you are not using Easy Install, you will need to browse the list for the operating system you are installing.
  4. 4
    Name your virtual machine. The name will help you identify it on your physical computer. It will also help distinguish between multiple virtual computers running different operating systems.
  5. 5
    Set the disk size. You can allocate any amount of free space on your computer to the virtual machine to act as the installed operating system’s hard drive. Make sure to set enough to install any programs that you want to run in the virtual machine.
  6. 6
    Customize your virtual machine’s virtual hardware. You can set the virtual machine to emulate specific hardware by clicking the “Customize Hardware” button. This can be useful if you are trying to run an older program that only supports certain hardware. Setting this is optional.
  7. 7
    Set the virtual machine to start.Check the box labeled “Power on this virtual machine after creation” if you want the virtual machine to start up as soon as you finish making it. If you don’t check this box, you can select your virtual machine from the list in VMware and click the Power On button.[2]
  8. 8
    Wait for your installation to complete. Once you’ve powered on the virtual machine for the first time, the operating system will begin to install automatically. If you provided all of the correct information during the setup of the virtual machine, then you should not have to do anything.
    • If you didn’t enter your product key or create a username during the virtual machine setup, you will most likely be prompted during the installation of the operating system.
  9. 9
    Check that VMware Tools is installed. Once the operating system is installed, the program VMware Tools should be automatically installed. Check that it appears on the desktop or in the program files for the newly installed operating system.
    • VMware tools are configuration options for your virtual machine, and keeps your virtual machine up to date with any software changes.

EditPart Three of Three:
Navigating VMware

  1. 1
    Start a virtual machine. To start a virtual machine, click the VM menu and select the virtual machine that you want to turn on. You can choose to start the virtual machine normally, or boot directly to the virtual BIOS.
  2. 2
    Stop a virtual machine. To stop a virtual machine, select it and then click the VM menu. Select the Power option.
    • Power Off – The virtual machine turns off as if the power was cut out.
    • Shut Down Guest – This sends a shutdown signal to the virtual machine which causes the virtual machine to shut down as if you had selected the shutdown option.
    • You can also turn off the virtual machine by using the shutdown option in the virtual operating system.
  3. 3
    Move files between the virtual machine and your physical computer. Moving files between your computer and the virtual machine is as simple as dragging and dropping. Files can be moved in both directions between the computer and the virtual machine, and can also be dragged from one virtual machine to another.
    • When you drag and drop, the original will stay in the original location and a copy will be created in the new location.
    • You can also move files by copying and pasting.
    • Virtual machines can connect toshared folders as well.
  4. 4
    Add a printer to your virtual machine. You can add any printer to your virtual machine without having to install any extra drivers, as long as it is already installed on your host computer.
    • Select the virtual machine that you want to add the printer to.
    • Click the VM menu and select Settings.
    • Click the Hardware tab, and then click Add. This will start the Add Hardware wizard.
    • Select Printer and then click Finish. Your virtual printer will be enabled the next time you turn the virtual machine on.
  5. 5
    Connect a USB drive to the virtual machine. Virtual machines can interact with a USB drive the same way that your normal operating system does. The USB drive cannot be accessed on both the host computer and the virtual machine at the same time.
    • If the virtual machine is the active window, the USB drive will be automatically connecterd to the virtual machine when it is plugged in.
    • If the virtual machine is not the active window or is not running, select the virtual machine and click the VM menu. Select Removable Devices and then click Connect. The USB drive will automatically connect to your virtual machine.
  6. 6
    Take a snapshot of a virtual machine. A snapshot is a saved state and will allow you to load the virtual machine to that precise moment as many times as you need.
    • Select your virtual machine, click the VM menu, hover over Snapshot and select Take Snapshot.
    • Give your Snapshot a name. You can also give it a description, though this is optional.
    • Click OK to save the Snapshot.
    • Load a saved Snapshot by clicking the VM menu and then selecting Snapshot. Choose the Snapshot you wish to load from the list and click Go To.[3]
  7. 7
    Become familiar with keyboard shortcuts. A combination of the "Ctrl" and other keys are used to navigate virtual machines. For example, "Ctrl," "Alt" and "Enter" puts the current virtual machine in full screen mode or moves through multiple machines. "Ctrl," "Alt" and "Tab" will move between virtual machines when the mouse is being used by 1 machine.

Installing Active Directory on Windows Server 2008 R2 Enterprise 64-bit

This article provides prerequisites and steps for installing Active Directory Domain Services (AD DS) on Microsoft Windows Server 2008 R2 Enterprise 64-bit (W2K8).
This article does not provide instructions for adding a Domain Controller (DC) to an already existing Active Directory Forest Infrastructure.

Contents

  1. Prepare for Active Directory Domain Services Installation
  2. Install Active Directory Domain Services (DCPROMO)

Prepare for Active Directory

Before you install AD DS on a Rackspace Cloud Server running Windows Server 2008 R2 Enterprise 64-bit (W2K8), you must perform the following prerequisite tasks.

Select Domain Name and Password

Select your domain name and know the domain administrator password that you want to use.
Note: Although it is not required, we recommend that you use a multiple name format for your domain name. For example, use domainName.com or domainName.local rather than simply domainName.

Specify the Preferred DNS Server

Windows Server 2008 can properly install and configure DNS during the AD DS installation if it knows that the DNS is local. You can accomplish this by having the private network adapter’s preferred DNS server address point to the already assigned IP address of the same private network adapter, as follows:
  1. From the Windows Start menu, openAdministrative Tools > Server Manager.
  2. In the Server Summary section of the Server Manager window, click View Network Connections.
    2K8_64R2_ADDS.jpg
  3. In the Network Connections window, right-click the private adapter and select Properties.
    2K8_64R2_ADDS(1).jpg
  4. Select Internet Protocol Version 4, and then click Properties.
    2K8_64R2_ADDS(7).jpg
  5.  Copy the IP address that is displayed in the IP address box and paste it into the Preferred DNS server box. Then, click OK.
    2K8_64R2_ADDS(2).jpg
  6. Click OK in the Properties dialog box, and close the Network Connections window.
Note: The last step for prepping W2K8 for AD is adding the proper Server Role. The “Active Directory Domain Services” Role will be added. This only installs the framework for W2K8 to become a DC and run AD. It does not promote the server to DC or install AD.

Add the Active Directory Domain Services Role

Adding the Active Directory Domain Services role installs the framework for Windows Server 2008 to become a DC and run AD DS. It does not promote the server to a DC or install AD DS.
  1. In the Server Manager window, open the Rolesdirectory and in the Roles Summary section, clickAdd Roles.
    2K8_64R2_ADDS(3).jpg
  2. On the Before You Begin page of the Add Roles Wizard, click Next.
  3. On the Select Server Roles page, select the Active Directory Domain Services check box, and then click Next on this page and on the Confirmation page.
    2K8_64R2_ADDS(4).jpg
  4. On the Installation Progress page, click Install
    2K8_64R2_ADDS(5).jpg
  5. On the Results page, after the role is successfully added, click Close.
    2K8_64R2_ADDS(6).jpg

Enable the Remote Registry

  1. Open the Server Manager window if it is not already open. 
  2. In the Properties area of the Local Servers page, click Remote Managemen
  3. Select the Enable remote management of this server from other computers check box.

Install Active Directory Domain Services (DCPROMO)

Now that you have prepared the server, you can install AD DS.
Tip: As an alternative to performing steps 1 through 3, you can type dcpromo.exe at the command prompt. Then, skip to step 4.
  1. If it is not already open, open the Server Manager window.
  2. Select Roles > Active Directory Domain Services.
  3. In the Summary section,click Run the Active Directory Domain Services Installation Wizard (dcpromo.exe).
    2K8_64R2_ADDS(8).jpg
  4. On the Welcome page of the Active Directory Domain Services Installation Wizard, ensure that the Use advanced mode installation check box is cleared, and then click Next.
    2K8_64R2_ADDS(10).jpg
  5. On the Operating System Capability page, clickNext.
    2K8_64R2_ADDS(11).jpg
  6. On the Choose a Deployment Configuration page, select Create a new domain in a new forest and then click Next.
    2K8_64R2_ADDS(12).jpg
  7. On the Name the Forest Root Domain page, enter the domain name that you choose during preparation steps. Then, click Next.
    2K8_64R2_ADDS(13).jpg
  8. After the installation verifies the NetBIOS name, on the Set Forest Functional Level page, selectWindows Server 2008 R2 in the Forest function level list. Then, click Next.
    2K8_64R2_ADDS(14).jpg
    The installation examines and verifies your DNS setting.
  9. On the Additional Domain Controller Options page, ensure that the DNS server check box is selected, and then click Next.
    2K8_64R2_ADDS(15).jpg
  10. In the message dialog box that appears, clickYes.
    2K8_64R2_ADDS(16).jpg
  11. On the Location for Database, Log Files, and SYSVOL page, accept the default values and then click Next.
    2K8_64R2_ADDS(17).jpg
  12. On the Directory Services Restore Mode Administrator Password page, enter the domain administrator password that you chose during the preparation steps. This is not your admin password that was emailed to you during the creation of your server, although you can use that password if you want to. Then, click Next.
    2K8_64R2_ADDS(18).jpg
  13. On the Summary page, review your selections and then click Next.
    The installation begins.
    2K8_64R2_ADDS(19).jpg
  14. If you want the server to restart automatically after the installation is completed, select theReboot on completion check box.
    2K8_64R2_ADDS(20).jpg
  15. If you did not select the Reboot on completion check box, click Finish in the wizard. Then, restart the server. 
    2K8_64R2_ADDS(21).jpg
  16. After a few minutes, reconnect to your server by using the Console in your Control Panel or RDP.
  17. To log in, perform the following steps:
        a.  Click Switch User, and then click Other User.    b.  For the user, enter the full domain name that you chose, followed by a back slash andAdministrator.
        c.  Enter the password that was emailed to you when you first built the server. If you changed your password
              for the local admin account to this server before you began the installation of AD   DS, use that password.
        d.  Click the log in button.
The installation of Active Directory Domain Services on your server is complete.

Thursday 4 September 2014

How Leaders Leverage Bright Spots in their Organisations

How Leaders Leverage Bright Spots in their Organisations 

Senior IT decision makers need to always keep an eye out for areas where there is dependency and alignment with other functions 

leadershipIt would not be unrealistic to say that the best functions of any individual come about truly when there is an alignment with the surrounding frameworks and environment. What does it mean? It obviously means that senior IT decision makers, in this case, need to always keep an eye out for areas where there is dependency and alignment with other functions.
This means it is the primary requisite for a leader to look at the bright spots in the organisation which can boost his role or performance and prove his leadership skills.

Leveraging the Bright Spot
While spotting is important, how leaders leverage and encourage that key area of focus and enable the business and other functions to see the advantage of the alignment becomes critical. This will help IT to move away from the mundane job of just being a support system meant only to keep the lights on.
“The primary requisite for a leader is to look at the bright spots in the organisation which can boost his role or performance and prove his leadership skills”
There are certain areas which provide senior IT managers with that opportunity that will enable them to hugely impact the business and prove leadership skills.
To make this happen, IT managers should fundamentally believe that new business ideas come from the IT department, as they begin to understand business needs. Start asking more questions of each business function, make an effort to understand that and tie it to the back end system; this would then trigger thoughts around innovation: what best can we do to meet this business goal? Obviously, any innovative thought coming from IT is definitely appreciated and recognised.

Find an opportunity to meet other leaders
I would strongly recommend that senior IT leaders create an opportunity for all leaders to meet each other on a periodic basis to understand each other’s functions and challenges and not work in silos.
It is crucial to share goals and achievements of these leaders, celebrate successes, highlight the bright spots of the nature of work and tie that to the outcome of the business—which, in a way, will fetch the necessary recognition. IT as a department, according to me, is clued into every function and there is no way that it needs to work in a silo environment. IT can be the catalyst, similar to an HR function maintaining the hygiene of the organisation.

Be a good listener
One other way in which senior IT teams can look at it is to move teams across functions on rotation so as to understand and empathise with the work culture and demands. A senior IT manager needs to be a good listener before imposing frameworks or rules; this will help in becoming a better leader.
I can recall an instance at a large bank inNorth America, where the DGM-IT displayed amazing leadership skills in enabling the entire business groups to migrate to Windows 7. It was not so much to do with technology play or convincing the teams. He pre-empted the objections that would come up during the implementation stage of Windows 7; his challenge was to prove his skills to pass the test.
The first step he took was to meet up with each team and listen to what their critical portions were and how it affected them if there was a change. The approach he took was to say, let me help you do this on a different platform and show you the advantages of using the new platform and how it eases your job. It was not just superficial talk; he created a live model of how the migration to the new module could enhance their performance. He also showcased the risk that could be caused to the business if the change was not made, while also showing how it could be transformed without much disruption. It paid off and he could successfully manage the change.

Reality based leadership
This is an interesting phenomenon catching up across enterprises in all the countries. This concept helps   leaders to step away from any irrational or hypothetical environment, and to break into the facts to derive conclusions.
This is necessary because of the changing market dynamics, as technology enables one to escalate to CXO levels. IT leaders need to aspire to reach that level and become advocates of change.

- See more at: http://www.itnext.in/itnext/articles/39047/leaders-identify-leverage-bright-spot-organisations#sthash.OfaUajZU.dpuf

Monday 1 September 2014

Career In BigData


Big data is a popular term used to describe the exponential growth and availability of data, both structured and unstructured. And big data may be as important to business – and society – as the Internet has become. Why? More data may lead to more accurate analyses.

More accurate analyses may lead to more confident decision making. And better decisions can mean greater operational efficiencies, cost reductions and reduced risk.

Big data defined

As far back as 2001, industry analyst Doug Laney (currently with Gartner) articulated the now mainstream definition of big data as the three Vs of big data: volume, velocity and variety1.
  • Volume. Many factors contribute to the increase in data volume. Transaction-based data stored through the years. Unstructured data streaming in from social media. Increasing amounts of sensor and machine-to-machine data being collected. In the past, excessive data volume was a storage issue. But with decreasing storage costs, other issues emerge, including how to determine relevance within large data volumes and how to use analytics to create value from relevant data.
  • Velocity. Data is streaming in at unprecedented speed and must be dealt with in a timely manner. RFID tags, sensors and smart metering are driving the need to deal with torrents of data in near-real time. Reacting quickly enough to deal with data velocity is a challenge for most organizations.
  • Variety. Data today comes in all types of formats. Structured, numeric data in traditional databases. Information created from line-of-business applications. Unstructured text documents, email, video, audio, stock ticker data and financial transactions. Managing, merging and governing different varieties of data is something many organizations still grapple with.
At SAS, we consider two additional dimensions when thinking about big data:
  • Variability. In addition to the increasing velocities and varieties of data, data flows can be highly inconsistent with periodic peaks. Is something trending in social media? Daily, seasonal and event-triggered peak data loads can be challenging to manage. Even more so with unstructured data involved.
  • Complexity. Today's data comes from multiple sources. And it is still an undertaking to link, match, cleanse and transform data across systems. However, it is necessary to connect and correlate relationships, hierarchies and multiple data linkages or your data can quickly spiral out of control.

The Future of Remote Work, According to Startups

  The Future of Remote Work, According to Startups No matter where in the world you log in from—Silicon Valley, London, and beyond—COVID-19 ...